mirror of
https://github.com/twisterarmy/gentoo-twister-overlay.git
synced 2025-03-12 05:22:57 +00:00
fist commit
This commit is contained in:
commit
4ec8670944
15
README.md
Normal file
15
README.md
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
Unofficial gentoo-twister-overlay
|
||||||
|
================================
|
||||||
|
|
||||||
|
A gentoo overlay for twister.
|
||||||
|
This overlay fetches the source from github, builds the twisterd and copies it to /usr/bin.
|
||||||
|
|
||||||
|
You can add the overlay to portage with:
|
||||||
|
|
||||||
|
# layman -o https://raw.github.com/ddorian1/gentoo-twister-overlay/master/gentoo-twister-overlay.xml -a twister
|
||||||
|
|
||||||
|
And than install twister (and dependencies) with:
|
||||||
|
|
||||||
|
# emerge -a twister
|
||||||
|
|
||||||
|
I only tested on amd64, but it should work on other platforms too.
|
15
gentoo-twister-overlay.xml
Normal file
15
gentoo-twister-overlay.xml
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
<?xml version="1.0" ?>
|
||||||
|
<repositories version="1.0">
|
||||||
|
<repo priority="50" quality="experimental" status="unofficial">
|
||||||
|
<name>twister</name>
|
||||||
|
<description lang="en">Unofficial twister overlay</description>
|
||||||
|
<homepage>https://github.com/ddorian1/gentoo-twister-overlay</homepage>
|
||||||
|
<owner type="person">
|
||||||
|
<email>johannes_schwab@gmx.de</email>
|
||||||
|
<name>Johannes Schwab</name>
|
||||||
|
</owner>
|
||||||
|
<source type="git">git://github.com/ddorian1/gentoo-twister-overlay.git</source>
|
||||||
|
<feed>https://github.com/ddorian1/gentoo-twister-overlay/commits/master.atom</feed>
|
||||||
|
</repo>
|
||||||
|
</repositories>
|
||||||
|
|
1
metadata/layout.conf
Normal file
1
metadata/layout.conf
Normal file
@ -0,0 +1 @@
|
|||||||
|
masters = gentoo
|
3
net-p2p/twister/Manifest
Normal file
3
net-p2p/twister/Manifest
Normal file
@ -0,0 +1,3 @@
|
|||||||
|
AUX 0.9.06_beta-twister-qt.pro.patch 846 SHA256 79bac6fd3324cb110c143c69b329ebd0eb82f3872bcdf291567120b3a037bf67 SHA512 776c0abf594c2b67a1f782d48c3a3fe72466fe9ac149cd0135a63450144ef75d75c70e0e471cff4cb757eeb6a7c9b2b6f15e55465148126e7317779bbff286bb WHIRLPOOL bbcf104598fdf5cc5be6ef9af241286d4878ff0ca7d3dd5751dc5552931aa35b102e26439991462260eee08f7e871d257595958e71bfc491f10cb1d8789f48f0
|
||||||
|
DIST 19ff320d24ad4926a90b778d95ecbccb843d1d1d.tar.gz 6259265 SHA256 cbd4bfc009839004bcb3d7687164e8acf5d77e68b0421b7d3ffb93a223aa588f SHA512 d15b528390093c8178ef78d645a40df2037efb23a4577b21759ad815c5eef25c2819098100894815ca9975a92ead4694b2fcc8fc02887bc63f5ecb42c73e6ab6 WHIRLPOOL e69278dc2de89bc8ffec4b9d1dc3b3ed6dcc47202804b1c2cd2e32439ec3bc2ec399cff2a75149cb0ecd198d47539a042344e758796b6c9fb7f3f1128c1314b3
|
||||||
|
EBUILD twister-0.9.06_beta.ebuild 783 SHA256 68d25e57f3b6f1ff5208c27dc0bd20d603c0494ead8f3b9e96ba58e21623ed05 SHA512 880d00aaca936fe73155bbe32b25a96269591673b81cbb10d38b70f1bfc8ac8c7014bc5398ead2daf250d1d8b9ff745a857c0ec692d5bc7ca4f89139aff55347 WHIRLPOOL 827a8ac7e56ec31010aa4ab70ed18fc644d675cea12245a8c91687ca280007fc231c4d9b450bbb0f0e4236e3dee4c986de5e6e0367dde3fa422c778999a327fb
|
20
net-p2p/twister/files/0.9.06_beta-twister-qt.pro.patch
Normal file
20
net-p2p/twister/files/0.9.06_beta-twister-qt.pro.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
diff --git a/twister-qt.pro b/twister-qt.pro
|
||||||
|
index 841791f..070c480 100644
|
||||||
|
--- a/twister-qt.pro
|
||||||
|
+++ b/twister-qt.pro
|
||||||
|
@@ -452,8 +452,13 @@ LIBS += -lssl -lcrypto -ldb_cxx$$BDB_LIB_SUFFIX
|
||||||
|
# -lgdi32 has to happen after -lcrypto (see #681)
|
||||||
|
win32:LIBS += -lws2_32 -lshlwapi -lmswsock -lole32 -loleaut32 -luuid -lgdi32
|
||||||
|
LIBS += -lboost_system$$BOOST_LIB_SUFFIX -lboost_filesystem$$BOOST_LIB_SUFFIX -lboost_program_options$$BOOST_LIB_SUFFIX -lboost_thread$$BOOST_THREAD_LIB_SUFFIX
|
||||||
|
-win32:LIBS += -lboost_chrono$$BOOST_LIB_SUFFIX
|
||||||
|
-macx:LIBS += -lboost_chrono$$BOOST_LIB_SUFFIX
|
||||||
|
+
|
||||||
|
+contains(USE_BOOST_46,1) {
|
||||||
|
+ message(Building with boost 1.4.6. Excluding chrono library.)
|
||||||
|
+} else {
|
||||||
|
+ message(Building with boost over 1.4.6. Including chrono library.)
|
||||||
|
+ LIBS += -lboost_chrono$$BOOST_LIB_SUFFIX
|
||||||
|
+}
|
||||||
|
|
||||||
|
contains(RELEASE, 1) {
|
||||||
|
!win32:!macx {
|
44
net-p2p/twister/twister-0.9.06_beta.ebuild
Normal file
44
net-p2p/twister/twister-0.9.06_beta.ebuild
Normal file
@ -0,0 +1,44 @@
|
|||||||
|
EAPI=5
|
||||||
|
inherit eutils
|
||||||
|
|
||||||
|
COMMIT="19ff320d24ad4926a90b778d95ecbccb843d1d1d"
|
||||||
|
|
||||||
|
DESCRIPTION="Peer-to-peer microblogging"
|
||||||
|
HOMEPAGE="http://twister.net.co/"
|
||||||
|
SRC_URI="https://github.com/miguelfreitas/twister-core/archive/${COMMIT}.tar.gz"
|
||||||
|
RESTRICT="mirror"
|
||||||
|
|
||||||
|
LICENSE="MIT BSD"
|
||||||
|
SLOT="0"
|
||||||
|
KEYWORDS="~amd64 ~x86"
|
||||||
|
|
||||||
|
RDEPEND="dev-libs/openssl
|
||||||
|
sys-libs/db
|
||||||
|
dev-libs/boost
|
||||||
|
net-libs/miniupnpc"
|
||||||
|
|
||||||
|
DEPEND="${RDEPEND}"
|
||||||
|
|
||||||
|
S="${WORKDIR}/twister-core-${COMMIT}"
|
||||||
|
|
||||||
|
src_configure() {
|
||||||
|
cd "${S}/libtorrent"
|
||||||
|
./bootstrap.sh
|
||||||
|
econf --enable-logging --enable-debug --enable-dht
|
||||||
|
|
||||||
|
cd "${S}"
|
||||||
|
qmake BDB_INCLUDE_PATH=/usr/include/db4.8
|
||||||
|
}
|
||||||
|
|
||||||
|
src_prepare() {
|
||||||
|
epatch "${FILESDIR}/${PV}-twister-qt.pro.patch"
|
||||||
|
}
|
||||||
|
|
||||||
|
src_compile() {
|
||||||
|
emake
|
||||||
|
}
|
||||||
|
|
||||||
|
src_install() {
|
||||||
|
mkdir -p "${D}usr/bin/"
|
||||||
|
cp "${S}/twisterd" "${D}usr/bin/twisterd"
|
||||||
|
}
|
1
profiles/repo_name
Normal file
1
profiles/repo_name
Normal file
@ -0,0 +1 @@
|
|||||||
|
twister
|
Loading…
x
Reference in New Issue
Block a user